Symptoms

  1. Unprovisioning "tenant" for APS application Trend Micro Security fails with the following error output:

    <html><head><title>Error</title></head><body>Internal Server Error</body></html>\n
    
  2. The following entries could be observer in debug-enabled /var/log/httpd/error_log of Trend Micro Security on the endpoint:

    # touch /var/www/html/TrendMicroWFBSS/config/.debug
    
    # tail -fn0 /var/log/httpd/error_log
    [2018-08-01 13:43:52.912567 UTC] TRACE #Request to APS controller [apsc-request-5b61b918dec9e]:
    PUT https://172.16.32.41:6308//aps/2/resources/0b9d3909-a4ad-499d-93a4-30a34ad74d97/notifications/89ccc4a8-c588-47f8-86ff-b0c920e341d3
    ...
    {"message":{"message":"Cancelling Subscription"},"details":{"message":"Trend Micro Worry Free Business Security Services"},"type":"activity","status":"inProgress"}
    
    [2018-08-01 13:43:52.953755 UTC] TRACE #Response from APS controller [apsc-request-5b61b918dec9e]:
    HTTP/1.1 500 Internal Server Error
    

Cause

The event notifications created by subscription were removed for some reason. Possible reasons:

  • Customer CP version was switched from UX1 to CCPv1 and back.

  • Another possible cause is that UX1 notification was removed by Periodic Task On-screen notifications cleaner (it could happen for old events with notifications older than 1 year). For example, Service Trend Micro Security 4.0-61 was provisioned on 1st of January, 2018. Customer got UX1 On Screen Notification about successful service provisioning. Corresponding notification will be cleaned up on 1st of January, 2019 (after 1 year). After 1st January of 2019 Trend Micro Security 4.0-61 service termination for such subscription could fail with symptoms above.

Resolution

The issue was found in Trend Micro Security 4.0-61 package and should be completely fixed in new package version.

Contact your TAM or PTA Team to apply an internal solution.

Internal content

Link on internal Article