Symptoms

Sales Order fails with the following error:

    "message": "Either offer id 64168b63-4bcc-41e0-b5cb-7dc548977620 is invalid or the country OM and/or locale en-US are not supported",

Cause

  1. Offer mentioned in the error output is either not available in the country or no longer supported.
  2. Offer might be related to syndication program.

Example:

  1. Customer from Oman tries to purchase offer 64168b63-4bcc-41e0-b5cb-7dc548977620 which is Office 365 Enterprise E5 Trial.
  2. In the latest Microsoft CSP Offer Matrix this offer is available for sale in the following list of coutries:

    Belgium;Bosnia and Herzegovina;Greece;Croatia;Italy;Indonesia;Jordan;Latvia;Mexico;Poland;Ukraine;Vietnam;Venezuela;Uruguay;United States;Taiwan;Trinidad and Tobago;Turkey;Thailand;Slovakia;Slovenia;Singapore;Sweden;Russia;Serbia;Romania;Qatar;Paraguay;Portugal;Puerto Rico;Philippines;Peru;Panama;New Zealand;Norway;Netherlands;Malaysia;Malta;Monaco;Luxembourg;Sri Lanka;Lithuania;Korea;Kenya;Japan;Ireland;Israel;Hungary;United Kingdom;France;Finland;Spain;Egypt;Estonia;Ecuador;Dominican Republic;Denmark;Germany;Czech Republic;Costa Rica;Cyprus;Colombia;Chile;Switzerland;Canada;Brazil;Bulgaria;Australia;Austria;Argentina;United Arab Emirates
    

Consequently, such offer can not be purchased in Oman.

Resolution

Use Microsoft CSP Offer Matrix in order to check if offer available in the country or not. Latest matrix can be obtained in the Partner Center Sell > Pricing and Offers > Cloud Reseller Offer Matrix > Check Allowed Countries.

Internal content