Symptoms

Task "Provisioning "Subscription" for APS application Office 365 fails with the following output:

APS Application Error:
500 Internal Server Error
[ApplicationUnknownError] The service has encountered an unknown error.

Body: {
"code": 500,
"message": "The service has encountered an unknown error",
"additionalNonlocalizableMessage": "",
"error": "ApplicationUnknownError",
"http_request": "POST /O365App/aps/subscriptions"
}

The following entry is represented in sitelog:

2019-03-06 14:09:46,267 [  88] INFO aps_endpoint: Need to create subscription for offer '031c9e47-4802-4248-838e-778fb1d2cc05' = 1.
2019-03-06 14:09:50,830 [  88] ERROR flow        : The service has encountered an unknown error
Partner Exception:
Error Category: BadInput
Service Error Payload:
Error code: 0
Error message: The service has encountered an unknown error

Context: Request Id: 932093cd-3a2a-5a26-ab94-a28203c0ca22, Correlation Id: 926093cd-4a1a-4d06-ab94-a28203c0ca22, Locale: en-US

Cause

The issue is on Microsoft side.

Request to place order and provision subscription fails. However, no clear cause of the issue/error code is provided.

In some cases the issue might be caused by incorrect MPN ID set to reseller.

Resolution

Contact Microsoft Support in order to clarify cause of the issue and discuss possible resolution.

Internal content

Link on internal Article