Symptoms
During APS "Symantec Endpoint Protection Cloud" deployment task
Execute operation 'initialize' with ID 669e3eb6-f7a9-436f-8509-5d311e51e1de on resource a6498a5d-df76-4947-ae08-eac264110937
fails with:Internal Server Error: Unable to create APS resource: Undefined property: stdClass::$__rel_globals at /var/www/html/sepc/lib/InitWizard/Manager.php:1604
While entering PCP > Services > Applications > Symantec Endpoint Protection Cloud > instance ID > 'Initialization' tab, it can be seen:
Initialization is in progress Please wait, while Symantec Endpoint Protection Cloud is being initialized ... Symantec Endpoint Protection Cloud is currently being initialized. You should be able to monitor the process inside the Task Manager (Operations > Tasks). The look up query to search by Name should be: *initialize*a6498a5d-df76-4947-ae08-eac264110937*
The following information can be seen in
/var/log/aps/symantec-epc.log
on the APS Endpoint Node:Aug 10 11:12:21 info APS-symantec-epc[9022]: INFO APSInit\Manager::discoverConfigApsType: Discovered InitConfig APS Type Id: http://symantec.com/aps/sepcApp/init_wiz ard/init_config/1.1 Aug 10 11:12:21 debug APS-symantec-epc[9022]: DEBUG APSInit\Manager::getInitStep: Returning step: create_aps_resources ... Aug 10 11:12:21 debug APS-symantec-epc[9022]: DEBUG APSInit\Manager::getInitStep: Returning step: create_aps_resources Aug 10 11:12:21 debug APS-symantec-epc[9022]: DEBUG APSInit\Manager::saveStepExecutionState: state saved Aug 10 11:12:21 err APS-symantec-epc[9022]: ERROR APSInit\Manager::createApsResources: Unable to create APS resource: Undefined property: stdClass::$__rel_globals at /var/www/html/sepc/lib/InitWizard/Manager.php:1604 Aug 10 11:12:21 debug APS-symantec-epc[9022]: DEBUG APSInit\Manager::getInitStep: Returning step: create_aps_resources Aug 10 11:12:21 debug APS-symantec-epc[9022]: DEBUG APSInit\Manager::saveStepExecutionState: state saved
Cause
APS package 2.6-607 has an issue with wizard configuration, It works correctly using defaults, but not using start wizard option. The issue was fixed in Symantec Endpoint Protection Cloud
since 2.8-76
.
Resolution
In order to avoid the issue, please use the APS Symantec Endpoint Protection Cloud
since 2.8-76 version.
- The failed task can be safely cancelled
Then uninstall the instance under PCP > Services > Applications > Symantec Endpoint Protection Cloud > instance ID > General > Uninstall
- and remove the application from OA under PCP > Services > Applications > Symantec Endpoint Protection Cloud > General > Delete application