Symptoms
A customer cannot change hostname of their VPS because the 'Change hostname' button is disabled in VPS Management in Odin Control Panel:
Cause
A customer does not have domain(s) hosted in Odin under their account. Odin allows to set hostname of a VPS to some existing customer's domain or to a sub-domain of a domain already existing in customer account.
E.g. if a customer already has domain customer.com in their account in OA, then customer may set VPS hostname to customer.com exactly or to subdomain.customer.com.
Resolution
First, a customer has to add a domain to their account in OA Control Panel:
- Register new domain
- Transfer existing domain
- Add existing domain registered elsewhere
As soon as a domain is added to a customer's account in OA, it will be possible to change hostname of their VPS in Control Panel.