Symptoms

When trying to open website, the following error appears:

The page cannot be displayed

OR

 Website can not be found    

Status of the domain in OA is In Sync.

Cause

Domain name cannot be resolved.

Resolution

Please follow the steps listed below to find where the problem is. Let's use the "domain.tld" domain as an example.

  1. First, domain nameservers must be found. This can be done with the following command:

    ~ whois domain.tld
    ......
    Nameserver Information:
    Nameserver: a.iana-servers.net.
    IP Address: 192.0.34.43
    Nameserver: b.iana-servers.net.
    IP Address: 193.0.0.236
    .....
    

    If there are no records about nameservers in the "whois" information, you should set them in the registrar - contact registrar to do it.

  2. Try to resolve the domain through its nameservers with the host or nslookup command. The output should appear as follows:

    ~ host domain.tld 139.91.1.10
    Using domain server:
    Name: 139.91.1.10
    Address: 139.91.1.10#53
    Aliases:
    domain.tld has address 192.0.34.166
    

    If an error "no servers could be reached" appears:

    ~ host domain.tld 193.0.0.236
    ;; connection timed out; no servers could be reached
    

    It means that named service is not running on the nameserver, or that port 53 is blocked by a firewall.

    If you get an empty answer or "not found" reply:

    ~ host domain.tld 193.0.0.236
    Using domain server:
    Name: 193.0.0.236
    Address: 193.0.0.236#53
    Aliases:
    Host domain.tld not found: 3(NXDOMAIN)
    

    It means that the domain you are trying to resolve doesn't exist on this nameserver. Please add it to the appropriate zone.

    The "(SERVFAIL)" error:

    ~ host domain.tld 193.0.0.236
    Using domain server:
    Name: 193.0.0.236
    Address: 193.0.0.236#53
    Aliases:
    Host domain.tld not found: 2(SERVFAIL)
    

    Indicates that the zone for the domain contains errors. Try to restart named service:

    # /etc/init.d/named restart
    

    and look in /var/log/messages for the "domain.tld" zone-loading errors.

    Try to use dig with trace output:

    # dig +trace domain.tld
    

    For Plesk: if you are able to find NS server in trace output from server machine and whois is showing correct output try to update DNS record for this domain:

    /usr/local/psa/admin/bin/dnsmng --update domain.tld
    

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