Symptoms
After termination of VPS Hosting Plesk subscription task Unprovisioning "PACIVPSHostingVPS" for APS application Cloud Infrastructure is failing:
Task ID 488063
Queue name aps_application_instance7 subscription_id1000199
Task name Unprovisioning "PACIVPSHostingVPS" for APS application Cloud Infrastructure
Task description Unprovisioning resource e4119d87-5257-4d28-9c62-5e9787dba19b of type 'vps' (http://www.parallels.com/paci/vps-hosting/vps/1.2) for APS application 'Cloud Infrastructure-17.13-39'
Subscription ID 1000199
Queue status Failed
Start not earlier than Jun-29-2018 17:36
Method name taskExecuteWorkflow on SCREF:SaaSManagerTasks:0
Last execution output
APS Application Error:
406 Not Acceptable
[ApplicationUnknownError] Unprovisioning: resource e4119d87-5257-4d28-9c62-5e9787dba19b of type 'vps' (http://www.parallels.com/paci/vps-hosting/vps/1.2) for APS application 'Cloud Infrastructure-17.13-39': [IM] P90050: There are still 1 VE(s) for this subscription.
Body: {
"source": "IM",
"message": "[IM] P90050: There are still 1 VE(s) for this subscription",
"notificationSent": false,
"error": "ApplicationUnknownError",
"http_request": "DELETE /vps/api/vps/e4119d87-5257-4d28-9c62-5e9787dba19b"
}
Following error appears in /var/log/pa/vps.aps.log
on OA MN during first task execution:
1315 > GET http://10.39.39.104:4465/paci/v1.0/cloud/ve-by-id/212
1315 > Authorization: <hidden>
1315 > x-paci-request-id: web_042aa7cd-a391-4be9-8125-2c5655c22d83_2079
1315 > group-id: 5dbefe0c-e830-4c0f-85a2-ff7184e02024
1315 > Accept: application/xml
2018-06-29 17:36:57,868 web_042aa7cd-a391-4be9-8125-2c5655c22d83_2079 INFO JerseyClientLoggingFilter [pa-rest task-69] - 1315 * [PACI<-IM] Client in-bound response
1315 < 404
1315 < Server: grizzly/2.3.22
1315 < x-paci-request-id: web_042aa7cd-a391-4be9-8125-2c5655c22d83_2079
1315 < Content-Length: 15
1315 < Date: Fri, 29 Jun 2018 10:36:57 GMT
1315 < Content-Type: text/plain
1315 <
Unknown VE: 212
Earlier VPS was recreated (button Recreate in CCP)
Cause
Software-related issue with internal ID CCU-18537
Resolution
Please contact your Technical Account Manager or pta@odin.com
in order to trace the status of the issue.
Workaround is available:
Find ID of terminated subscription in the task output. In example above it is 1000199
Find corresponding VPS in PCP > Services > Cloud Infrastructure and remove it
- Restart failed task