Symptoms
/tmp
folder on the POA management node is filled up with files like this:
0 Dec 16 12:13 ff5896c6-ecf8-4af1-81e5-d12f93bd6a03.20141216T121311.238295
0 Dec 16 12:21 ff5896c6-ecf8-4af1-81e5-d12f93bd6a03.20141216T122113.991363
0 Dec 16 12:27 ff5896c6-ecf8-4af1-81e5-d12f93bd6a03.20141216T122739.180987
0 Dec 16 12:36 ff5896c6-ecf8-4af1-81e5-d12f93bd6a03.20141216T123622.211486
Cause
These files are generated by APS service controller if APS development mode is enabled in:
System > Settings > System properties
APS controller creates a file in the /tmp
on each rest request: when it is a GET
request, the file is empty, when it is a POST
request - file contains POST parameters.
When APS development mode is disabled APS service controller creates file in /tmp
for POST requests only.
APS service controller does not clean up these temporary files when APS development mode is disabled and does not have periodic clean up for these files.
There is an existing request to implement such cleanups or to prevent APS service controllers from creating such files in /tmp
.
The request ID is APS-18125
Resolution
Please contact your account manager to get the actual status of the request.
To prevent mass generation of zero-sized files - disabled APS development mode if it is not being used.
The following cron
task can be submitted to workaround the issue:
Issue the following command on the Management node:
root@core# crontab -e
Fill the following parameters:
0 0 * * * find /tmp -regextype posix-egrep -regex '/tmp/[a-z0-9A-Z\.-]{59}' -mtime +3 -exec rm -f {} \;
In this example cron
task will be executed daily at 00:00. You may adjust this parameter according to your needs. Files modified later than 3 days ago will be removed in the case.