Symptoms
O365 task fails with:
APS Application Error:500 Internal Server Error
[ApplicationUnknownError] Provisioning: resource ff7fd089-90c9-4b9e-99c7-8c05ffb532c4 of type 'asyncOperations' (http://www.parallels.com/Office365/AsyncOperation/1.0) for APS application 'Office 365-6.4-63': Subscription has multiple resources.
Cause
Affected subscriptions have been upgraded to the proper transition plan, and then a plan switch was initiated to an enterprise plan.
Resolution
Restore subscriptions to the initial service plans, using the following procedure:
- Add initial service plan - "Office 365 Midsize Business" to the "upgrade" tab of the current plan - "Office 365 - Enterprise Business".
- Perform switch plan to the "Office 365 Midsize Business".
- Add 51 seats to the customer subscription (There are 51 licenses in MOP for "MidSize Business" now).
On step 2 the subscription will be deactivated but after the step 3 it will be reactivated back. User data will not be lost.