Purpose

Operations Automation updates installer is an utility for downloading and installing updates and hotfixes.

It is invoked via the command line on the management node.

Procedure of installing updates and hotfixes

For OA 7.3, 7.4, 8.0 and 8.2

  1. On the management node, run:

    oa-update --install
    

OA 7.3, 7.4 and 8.0: Installing selected hotfixes only

  1. On the management node, run:

    oa-update
    

    The list of available hotfixes will be displayed.

  2. Run the command, specifying the IDs of necessary hotfixes and separating them with commas:

    oa-update --install --hotfix <Hotfix1_ID>,<Hotfix2_ID>
    

    where Hotfix1_ID and Hotfix2_ID are the IDs of hotfixes you want to install.

    Example:

    oa-update --install --hotfix KB123456,KB123457
    

Note: For the full list of update installer parameters, refer to the Upgrade Workflow Guide: section for 8.0, 7.4 and version 7.3, respectively.

For 7.2

  1. On the management node, run:

    oa-update --install
    
  2. Once you have the updates installation finished, you may need also to update Billing. This step is required when a hotfix you installed affects Billing. The necessity to update Billing is indicated by a warning message displayed during the --install procedure, similar to this one:

    [WARNING] Host #2 (some.hostname.provider.com) is one of Billing hosts and have to be updated later, with launch "pa_updates_installer --update-billing"
    

    If you had this message displayed, after the --install procedure, run the command:

    oa-update --update-billing
    

OA 7.2: Installing selected hotfixes only

  1. On the management node, run:

    oa-update
    

    The list of available hotfixes will be displayed.

  2. Run the command, specifying the IDs of necessary hotfixes and separating them with commas:

    oa-update --install --hotfix <Hotfix1_ID>,<Hotfix2_ID>
    

    where Hotfix1_ID and Hotfix2_ID are the IDs of hotfixes you want to install.

    Example:

    oa-update --install --hotfix KB123456,KB123457
    

For 7.1

  1. On the management node, run:

    /usr/bin/pa_updates_installer --install
    
  2. Once you have the updates installation finished, you may need also to update Billing. This step is required when a hotfix you installed affects Billing. The necessity to update Billing is indicated by a warning message displayed during the --install procedure, similar to this one:

    [WARNING] Host #2 (some.hostname.provider.com) is one of Billing hosts and have to be updated later, with launch "pa_updates_installer --update-billing"
    

    If you had this message displayed, after the --install procedure, run the command:

    /usr/bin/pa_updates_installer --update-billing
    

OA 7.1: Installing selected hotfixes only

  1. On the management node, run:

    /usr/bin/pa_updates_installer
    

    The list of available hotfixes will be displayed.

  2. Run the command, specifying the IDs of necessary hotfixes and separating them with commas:

    /usr/bin/pa_updates_installer --install --hotfix <Hotfix1_ID>,<Hotfix2_ID>
    

    where Hotfix1_ID and Hotfix2_ID are the IDs of hotfixes you want to install.

    Example:

    /usr/bin/pa_updates_installer --install --hotfix KB123456,KB123457
    

For 7.0

  1. On the management node, run:

    /usr/local/pem/bin/pa_updates_installer --install
    
  2. Once you have the updates installation finished, you may need also to update Billing. This step is required when a hotfix you installed affects Billing. The necessity to update Billing is indicated by a warning message displayed during the --install procedure, similar to this one:

    [WARNING] Host #2 (some.hostname.provider.com) is one of Billing hosts and have to be updated later, with launch "pa_updates_installer --update-billing"
    

    If you had this message displayed, after the --install procedure, run the command:

    /usr/local/pem/bin/pa_updates_installer --update-billing
    

OA 7.0: Installing selected hotfixes only

  1. On the management node, run:

    /usr/local/pem/bin/pa_updates_installer
    

    The list of available hotfixes will be displayed.

  2. Run the command, specifying the IDs of necessary hotfixes and separating them with commas:

    /usr/local/pem/bin/pa_updates_installer --install --hotfix <Hotfix1_ID>,<Hotfix2_ID>
    

    where Hotfix1_ID and Hotfix2_ID are the IDs of hotfixes you want to install.

    Example:

    /usr/local/pem/bin/pa_updates_installer --install --hotfix KB123456,KB123457
    

Internal content

Link on internal Article