Symptoms

Customers receive notification with attached PDF document which differs from the HTML source defined in PBA.

Cause

The PDF conversion tool used does not support CSS formatting and/or does not convert national characters properly.

Resolution

By default htmldoc utility is used for conversion, which does not support CSS, does not have tables formatting, etc.

The steps to change the PDF conversion utility used are described in the documentation.

If you experience issues with displaying non-ASCII characters in PDF attachments to notifications consider using the iconv utility for proper encoding, for example, first process the source HTML file using the iconv utility and then process it by the htmldoc utility, e.g.:

iconv -c --from-code UTF-8 --to-code ISO8859-1 @@SrcNames@ | htmldoc -t pdf13 -f @@DstName@ --webpage --no-embedfonts --charset 8859-1 -

If you would like to have the more document formatting, a different utility is to be used. You can install any third-party tool, e.g. html2pdf, the conversion command is to be changed accordingly.

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