Symptoms
Cannot start PBA on the Linux based node:
# service pba start Starting Stellart Service Manager: [ OK ] Starting Application Transaction Manager: [ OK ] Starting Stellart Database Multiplexer: [ OK ] Starting Stellart XML RPC Proxy Server: [ OK ] Starting PBA PSS Container: [FAILED] Starting Stellart WWW Server: [FAILED] Starting Stellart XML RPC Server: [FAILED] Starting Stellart XML RPC Server: [FAILED] Starting Stellart XML RPC Server: [FAILED] Starting Stellart XML RPC Server: [FAILED] Starting Stellart XML RPC Server: [FAILED] Starting Parallels Business Automation dependencies: [FAILED]
The following entry appears in log of any PBA container which cannot be started, e.g. in the
/usr/local/bm/log/PSS.log
or/usr/local/bm/log/xmlrpcd.log
:[13-11-01 18:24:27.719 PSS_Contain TH31869 FTL] [../stlrt/io/tcpsocket.cpp:382] Connection refused: 127.0.0.1:5223.
Cause
The "Application Transaction Manager" (ATM) container is configured to listen to 'localhost' instead of '127.0.0.1'. If the PBA Management Node has IPv6 support, the ATM container starts to listen to the IPv6 address of localhost instead of IPv4 address.
The 'netstat' utility shows that the 'atm' process listens to the '::1' IP address instead of '127.0.0.1':
# netstat -antp | grep atm
tcp 0 0 ::1:5223 :::* LISTEN 31861/atm
PBA containers cannot connect to the 'Application Transaction Manager' using IPv4 connection and fail to start.
Resolution
Configure the "Application Transaction Manager" to listen to the IPv4 interface:
Log into the PBA Application server via SSH as root
Open the
/usr/local/bm/conf/_amt_service_.res
file in editorChange the 'localhost = 5223' to '127.0.0.1 = 5223' in the [Hosts] section as below:
[Hosts] 127.0.0.1 = 5223