Symptoms

Customer receives invoice notification where "Start Date" and "End Date" fields have incorrect dates set. Time is moved back/forward.

Cause

The issue may be caused by time zone misconfiguration between Billing Application server, Billing Database server or Billing Database itself.

Resolution

In order to check if the issue is caused by time zone misconfiguration the following actions should be performed:

  1. Connect to Billing Application server and execute the following command to check timezone used by server:

    timedatectl | grep -i 'time zone'
    

For example:

    [root@billing]# timedatectl | grep -i 'time zone'
    Time zone: Asia/Manila (+08, +0800)

2. Connect to Billing Database server and check time zone via the sme command.

For example:

    [root@badb] timedatectl | grep -i 'time zone'
    Time zone: Asia/Manila (+08, +0800

3. Connect to Billing Postgresql database and check its time zone via the query below:

    pba=# show timezone;

For example:

    pba=# show timezone;
     TimeZone
    ----------
     UTC
    (1 row)

In case if time zone is different at any of the aforementioned steps from the correct one it is necessary to change it to required timezone. This will fix the issue.

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