This article contains troubleshooting information that you can use when switching subscriptions from the Hosted Exchange 2016 module to the Hosted Exchange application.

Table of Contents

Common Issues

Exchange Objects of Disabled Subscription Cannot Be On-boarded (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Subscription 1000013 is disabled.

Cause

Exchange objects of subscriptions that are disabled in Operations cannot be on-boarded.

Resolution

Possible actions:

  • Make the subscription enabled. When you process it, make it disabled. You can use either Billing or the CloudBlue Commerce XMLRPC API to do this (see the pem.enableSubscription and pem.disableSubscription methods).
  • You can remove the subscription if it is not used.

Process of On-boarding Exchange Objects Is Already in Progress (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Hosted Exchange application resources are being created for subscription 1000013.

Cause

The process of on-boarding Exchange objects of the subscription is already in progress.

Resolution

Wait for the process to complete. Then, continue processing the subscription. You can see the status of the process in the control panel at Services > Applications > application > application instance > Exchange tab > Switch to Exchange Application subtab.

Exchange Objects Are Already On-boarded (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Hosted Exchange application resources are already created for subscription 1000013.

Cause

The process of on-boarding Exchange objects of the subscription is already performed.

Resolution

Check the status of the process in the control panel at Services > Applications > application > application instance > Exchange tab > Switch to Exchange Application subtab. Then, continue processing the subscription.

Unsupported 'BlackBerry Messaging' Resource (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

An unsupported BlackBerry resource is used in subscription 1000013. Remove the BlackBerry service before switching to the Hosted Exchange application.

Cause

The Hosted Exchange application does not support the 'BlackBerry Messaging' resource, whereas the usage of the resource is non-zero in the subscription.

Resolution

For every mailbox of the subscription, turn the BlackBerry wireless service off. Then, continue processing the subscription.

Unsupported Exchange Server Version (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

The version of Exchange Server used by subscription 1000013 is not supported by the Hosted Exchange application. Only Exchange Server 2016 is allowed.

Cause

The Hosted Exchange application supports Microsoft Exchange Server 2016 only, whereas the subscription uses another version.

Resolution

Migrate the subscription to Microsoft Exchange Server 2016. Then, continue processing the subscription.

To migrate from the Hosted Exchange 2010 module to the Hosted Exchange 2016 module, use the instructions at https://docs.cloudblue.com/oa/8.0/premium/content/MS-Exchange-Hosting-Guide/Exchange-2010-to-Exchange-2016-Transition.htm.

To migrate from the Hosted Exchange 2013 module to the Hosted Exchange 2016 module, use the instructions at https://docs.cloudblue.com/oa/8.0/premium/content/MS-Exchange-Hosting-Guide/Transition-2013-2016/Exchange-2013-to-Exchange-2016-Transition.htm.

Exchange Object Is Not Up-to-date (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

The Exchange object 'mailboxes' (ID 117) is not up-to-date. In the task manager, make sure that all tasks related to the Exchange object are processed.

Cause

The Exchange object is not up-to-date, and, as a result, it cannot be on-boarded. Typically, this means that the subscription that the Exchange object belongs to has one or more unprocessed tasks in the task manager.

Resolution

In the task manager, find and run all unprocessed tasks related to the subscription. As soon as the tasks are successfully finished, continue processing the subscription.

Issue with Custom Email Addresses / Shared Domain Email Addresses (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Mailbox email address 'email@custom-domain.com' is not allowed. The domain part of an email address should be based on a domain linked with the Exchange service.

Cause

The Hosted Exchange application supports neither custom email addresses, which are email addresses based on domains that are not linked with the Exchange service, nor shared domain email addresses, which are email addresses based on domains of vendor accounts.

Resolution

Remove such email addresses from necessary Exchange objects. Then, continue processing the subscription.

Issue with Linked Mailboxes (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Unable to on-board the linked mailbox linked-mailbox@domain.com since linked mailboxes are not supported by the Hosted Exchange application.

Cause

The Hosted Exchange application does not support linked mailboxes. As a result, linked mailboxes cannot be on-boarded.

Resolution

Make all necessary linked mailboxes ordinary. For details, see the instructions at https://docs.cloudblue.com/oa/8.0/premium/content/MS-Exchange-Hosting-Guide/Managing-Linked-Mailboxes.htm.

Issue with Vendor Subscriptions (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Failed to create Hosted Exchange application resources for subscription #1 which belongs to vendor account #1. The Hosted Exchange application does not support vendor accounts.

Cause

The Hosted Exchange application does not support the scenario in which Exchange objects are created directly under a vendor account subscribed to the Hosted Exchange application's service plans.

Resolution

Consider removing all Exchange objects created directly under the vendor account. If necessary, re-create these Exchange objects under a separate customer account.

Issue with 'Hosted Exchange Organization' Resource (Common Issue)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Subscription for Hosted Exchange application must contain one Organization resource with non-zero limit. It is not the case for subscription 1000013.

Cause

The Hosted Exchange application's subscription must include one and only one 'Hosted Exchange Organization' resource, whose limit must be set to 1. The subscription does not comply with this requirement.

Resolution

Check and adjust the subscription, as well as its service plan. Then, continue processing the subscription.

Switching Subscriptions by Swapping Resources

Subscription Does Not Include All Necessary Resources (Swapping Resources)

Symptoms

During the process of on-boarding Exchange objects, which is launched with switch-to-hosted-exchange-app.py switch-app ..., an error message like this appears:

Hosted Exchange application resources are not present in subscription 1000013 or have zero limits.

Cause

The Hosted Exchange application's subscription must include all necessary resources with correct limits, as described in the Hosted Exchange Integration Provider's Guide >> Getting Ready for Selling Hosted Exchange Services > Preparing Resources. The subscription does not comply with the requirement.

Resolution

Make sure that the subscription is extended with the necessary Hosted Exchange application resources as described in Hosted Exchange Application Provider's Guide >> Switching Subscriptions from the Hosted Exchange 2016 Module to the Hosted Exchange Application > Switching Subscriptions by Swapping Resources > Extending Subscriptions and Onboarding Exchange Objects. Then, continue processing the subscription.

Switching Subscriptions by Changing Service Plans

Subscription Is Based on Service Plan That Is Not in JSON Configuration File (Changing Service Plans)

Symptoms

switch-to-hosted-exchange-app.py switch-plan ... shows an error message like this for a subscription:

[WARNING] Subscription #1000001 migration skipped: the subscription is based on service plan #4 which is not mentioned as current plan or destination plan in switch plan settings

Cause

The script cannot find the service plan that the subscription is currently based on in its JSON configuration file.

Possible reasons:

  • The subscription must be switched, but the JSON configuration file does not contain service plan mappings for the subscription.
  • The subscription must not be switched but is processed by mistake. This can happen when a wrong subscription is specified. This can also happen when the script is run with either --accounts or --accounts-file, and it processes all the subscriptions of an account, including non-Hosted Exchange subscriptions.

Resolution

Possible actions:

  • If the subscription must be switched, correct the JSON configuration file by adding respective service plan mappings. Then, continue processing the subscription.
  • If the subscription must not be switched, ignore the error message.

Subscription Is Based on Service Plan That Is Defined as Destination Service Plan in JSON Configuration File (Changing Service Plans)

Symptoms

switch-to-hosted-exchange-app.py switch-plan ... shows an error message like this for a subscription:

[WARNING] Subscription #1000002 migration skipped: the subscription is based on service plan #7 which is destination plan according to switch plan settings

Cause

In the JSON configuration file, the service plan is defined as a destination service plan (destination_plan) but is not defined as a current service plan (current_plan).

Possible reasons:

  • The subscription is completely switched (the subscription was switched from its source service plan to its intermediate service plan, and from its intermediate service plan to its target service plan).
  • The subscription is not completely switched, whereas the JSON configuration file does not contain all necessary service plan mappings for the subscription.

Resolution

Possible actions:

  • If the subscription is completely switched (the subscription was switched from its source service plan to its intermediate service plan, and from its intermediate service plan to its target service plan), ignore the error message.
  • If the subscription is not completely switched, correct the JSON configuration file by adding respective service plan mappings. Then, continue processing the subscription.

Only Active and Running Subscriptions Can Be Switched (Changing Service Plans)

Symptoms

switch-to-hosted-exchange-app.py switch-plan ... shows an error message like this for a subscription:

[WARNING] Subscription #1000012 migration skipped: it's only allowed to switch Active and Running subscriptions while current status is Active and Changing Plan

Cause

The subscription is not Active and Running in Billing, and, as a result, it cannot be switched.

Resolution

Check the subscription in Billing. Follow the Billing documentation to resolve the issue. As soon as the subscription becomes Active and Running, you can continue switching it.

Failed to Create Order That Changes Service Plan of Subscription (Changing Service Plans)

Symptoms

switch-to-hosted-exchange-app.py switch-plan ... shows an error message like this for a subscription:

[ERROR] Failed to create switch order for subscription #1000013: <Fault -1: 'Cannot Upgrade/Downgrade Resources for Subscription #1000013: there is already an Upgrade/Downgrade Order #CH000100 in status New(NW). This order prohibits placing an order of the same order type (per subscription). Please either cancel conflicting order or wait until it is processed by the system.
Error Code: 0x177b482b.
Report ID: 13
'>

Cause

One of the orders that change the subscription's service plan cannot be created due to an issue in Billing.

Resolution

Follow the Billing documentation to resolve the issue. As soon as you resolve the issue, you can continue processing the subscription.

Failed to Create Order That Synchronizes Additional Amounts of Resources (Changing Service Plans)

Symptoms

switch-to-hosted-exchange-app.py switch-plan ... shows an error message like this for a subscription:

[ERROR] Failed to create an upgrade order for subscription #1000013: <Fault -1: 'Cannot Upgrade/Downgrade Resources for Subscription #1000013: there is already an Upgrade/Downgrade Order #CH000100 in status New(NW). This order prohibits placing an order of the same order type (per subscription). Please either cancel conflicting order or wait until it is processed by the system.
Error Code: 0x177b482b.
Report ID: 13
'>

Cause

The order that synchronizes the additional amounts of the Hosted Exchange application's resources with the additional amounts of the Hosted Exchange module's resources in the subscription cannot be created due to an issue in Billing.

Resolution

Follow the Billing documentation to resolve the issue. As soon as you resolve the issue, you can continue processing the subscription.

Failed to Change Service Plan of Subscription When Order is Processed (Changing Service Plans)

Symptoms

switch-to-hosted-exchange-app.py switch-plan ... shows an error message like this for a subscription:

[WARNING] Subscription #1000013 migration: upgrade order #1000075 is not completed yet

Cause

Before a subscription is switched from its intermediate service plan to its target service plan, an order that synchronizes the additional amounts of the Hosted Exchange application's resources with the additional amounts of the Hosted Exchange module's resources in the subscription is placed. If this order is not processed in a period of time, the script does not change the subscription's service plan and shows an error message like this.

Resolution

Check the order in Billing. As soon as the order is processed, you can continue processing the subscription.

Subscription Does Not Include All Necessary Resources (Changing Service Plans)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Hosted Exchange application resources are not present in subscription 1000013 or have zero limits.

Cause

The Hosted Exchange application's subscription must include all necessary resources with correct limits, as described in the Hosted Exchange Integration Provider's Guide >> Getting Ready for Selling Hosted Exchange Services > Preparing Resources. The subscription does not comply with the requirement.

Resolution

Check and adjust the subscription, as well as its service plan. Then, continue processing the subscription.

Issue with 'Hosted Exchange Application' Resource (Changing Service Plans)

Symptoms

During the process of on-boarding Exchange objects, which is launched either with switch-to-hosted-exchange-app.py switch-app ... or through the control panel, an error message like this appears:

Hosted Exchange application reference resource is not present in subscription 1000013 or have zero limit.

Cause

The Hosted Exchange application's subscription must include one and only one 'Hosted Exchange Application' resource, whose limit must be set to 1. The subscription does not comply with this requirement.

Resolution

Check and adjust the subscription, as well as its service plan. Then, continue processing the subscription.

APS Resource Cannot Be Created for Exchange Object (Changing Service Plans)

Symptoms

A task named "Execute operation "propagation"" fails with an error message like this:

Creation of resource with type "http://www.odin.com/pa/aps/exchange/types/mailbox/1.0" is not allowed. Make sure that corresponding Resource is included into Subscription and does not exceed its limit.

Cause

Possible reasons:

  • The subscription that the task belongs to does not include the respective resource of the Hosted Exchange application.
  • In the subscription, "the" limit on the respective resource of the Hosted Exchange application is reached.

Resolution

Check and adjust the subscription. Then, "restart" the task in the task manager.