Symptoms

A scheduled RDE report of type "With Every Invoice" lacks details from a customer's order. The missing details can be found in a one-time report that is made on-demand.


Cause

The issue may affect orders where the reseller provides volume pricing for its customers while paying using a one-tier model to its vendor. In this case, the customer's invoice usually contains more details than there are reseller's transactions related to a certain customer's purchase. For example, if a reseller provides volume pricing to the end-customer but pays to its own vendor using a one-tier price model, then there may be several details in the customer's billing order (like shown on the image below) but only one such detail for the reseller. Under the mentioned circumstances, only 1-tier details will be rendered in the RDE report file but no 2-tier details will be shown. This behaviour is considered as incorrect and tracked as a software bug OA-12303.


Resolution

Use a One-Time report instead of its scheduled per-invoice version. For more information on the status of OA-12303, contact your Technical Account Manager or Service Delivery Manager.