Symptoms


Sales or Upgrade order for Office 365 subscription fails with the following error:


The order provisioning has failed.
The last error - "Service Creation Failed: Platform service was not created. Task "Provisioning "Tenant" for APS application Office 365(https://o365aeh.contoso.local:443/Office365GatewayApplication01/aps/)" (id = 71612) is failed with error: "'500 Internal Server Error' received from 'POST https://o365aeh.conn-now.local:443/Office365GatewayApplication01/aps/subscriptions': The offer dd3496ba-a49b-4475-9f40-8c333709ef87 is not purchasable - Item DC3496BA-A49B-4375-9F40-8C334709EF87 referenced by line item 0 supports quantity range from 3000 to 3000..



Cause


Some Microsoft offers have minimum and maximum allowed quantity of licenses for subscription (https://docs.microsoft.com/en-us/partner-center/pricing-and-offers#offer-limits):


Some license-based offers have certain rules and limitations that prohibit multiple purchases for the same customer. These rules apply to most trials and many of the small business offers. Small business offers are defined by those offers that have a maximum license count that is less than 300.

These purchasing constraints are defined as part of the offer configuration and can be found by looking in the offer list matrix. Two columns of data work together to define the enforcement: 1. Offer Limit Scope and 2. Offer Limit. The constraints are enforced during a purchase. The catalog in partner center will disallow a partner from purchasing more offers than the rules allow. Any attempt to violate the constraints will result in an error.


Error above appears when Odin Automation tries to provision subscription with quantity not supported by this offer.



Resolution


Reconfigure resource rate in service plan in accordance with Microsoft requirements for the offer. Requirements could be obtained in Offer Matrix provided by Microsoft in Partner Center (see details here https://docs.microsoft.com/en-us/partner-center/pricing-and-offers#offers-matrix).