Symptoms

"Cleanup packages on host hosname.example.com" task fails with 'null' as output.


In /var/log/pa/core.log on the Management Node, the following error message can be found:

Feb 20 11:37:10.633 : DBG [task:37839209:5218 Thread-31950-(ActiveMQ-client-global-threads):156823 pau]: c.p.p.tracer exit by exception: com.parallels.pa.service.idp.ejb.IDPSupportBean.removeUser correlationId task:37839209:5218 java.lang.NullPointerException: null
        at deployment.core-ear.ear.idp-ejb.jar//com.parallels.pa.service.idp.ejb.IDPSupportBean.removeUser(IDPSupportBean.java:193)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
        at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
        at java.base/java.lang.reflect.Method.invoke(Method.java:566)


IDP service is enabled in Provider Control Panel > Services > IDP.


Same situation can appear on host registration.


Cause

Such unexpected behaviour is caused by software bug #OA-9981.


Resolution

A fix is planned in future software updates. To workaround the issue, temporary disable IDP in Provider Control Panel > Services > IDP to process the affected tasks.