Symptoms


On attempt to open tab of some APS application (Provider's Control Panel > Services > Applications) in UI, tab of other APS application is actually represented.


Tabs of some APS applications are missing in Customer's Control Panel.


APS Booster is deployed in a platform.


The platform was recently upgraded to Odin Automation 8.3, CloudBlue Commerce 20.4, or later.


The issue might also be experienced with a different symptom: an attempt to open and APS2 instance goes into infinite loop.

This might happen an application endpoint that is attempted to be displayed is not available.

In this situation a connection issue error might be observed in browser developer tools and core.log. For example:


message: "Could not invoke endpoint url 'https://172.19.8.25:8081/biapplication/rest/biapplication/2daf6901-72bb-42b5-9740-7e7e0959e0e8/taskStatus' 

of application instance with UUID 'c9a561fd-c0fc-4cc8-9779-cd67da22fa9d'. 

RESTEASY004655: Unable to invoke request: No route to host (Host unreachable)"



Cause


There are three Software-related issues can occur:

I. #OA-11939. Permissions to the tables "aps_property_enum_info" and "aps_operation_param" in the Management node database are missing for database users utilized by the platform.


II. #OA-13180. Permissions to the table "aps_type_schema" in the Management node database are missing for database users utilized by the platform.


III. #OA-11947. If navigation types cache is empty, it will never be filled again




Resolution


Contact CloudBlue Technical Support in order to apply a fix for the issue.


Link to an internal article