Symptoms


There is an attempt to upgrade Office 365 application. Endpoint was upgraded successfully, but task "Upgrading resources of application 'Office 365'" fails with the following error:


RESTEASY004655: Unable to invoke request
Connection reset


The following error could be seen in core.log :


Jun  6 08:03:39.279 : DBG [task:3789579:85 Thread-1230-(ActiveMQ-client-global-threads):5033 pau]: c.p.p.s.c.e.EndpointExecutorBean endpoint call failed: com.parallels.pa.service.aps.api.APSEndpointIOException: Could not invoke endpoint url 'https://192.168.0.10:443/Office365GatewayApplication01CSP/aps/office365app/e44aed5d-314f-4d4e-aa6f-76a26d978f64/upgrade?version=19.1.3-7' of application instance with UUID 'c138088f-7f3f-4fce-be68-88bcc69e15fb'. RESTEASY004655: Unable to invoke request: Connection reset


The following event is represented in Event Viewer on the application endpoint:


Schannel
Event ID: 36888
The following fatal alert was generated: 20. The internal error state is 960.



Cause


Management Node is unable to establish secured connection with the endpoint because SSL/TLS settings are misconfigured on the endpoint side.


Resolution

Configure SSL/TLS settings for the endpoint as described in article.