Symptoms


Customer tries to purchase trial Office 365 subscription. Task "Provisioning "Tenant" for APS application Office 365" fails with the following message:


'500 Internal Server Error' received from 'POST https://172.27.148.64:443/O365QBSEU/aps/subscriptions': The offer c0bd2e08-11ac-4836-bdc7-3712e744922f is not purchasable - Availability C0BD2E08-11AC-4836-BDC7-3712E744922F referenced by line item 0 does not support billing cycle 'Monthly'.. 

The following entry could be seen in apilog (the entry is represented only if Microsoft 365 version 20.1 or above is installed):


2020-06-20 10:14:53,793 <18612> [ 171] INFO apilogger   : PC SDK: order new subscription for customer microsoft tenant id '***'
{
  "ReferenceCustomerId": "***",
  "BillingCycle": "monthly",
  "LineItems": [
    {
      "LineItemNumber": 0,
      "OfferId": "c0bd2e08-11ac-4836-bdc7-3712e744922f",
      "FriendlyName": "#1235645: Microsoft 365 Business Standard Trial",
      "Quantity": 25,
      "PartnerIdOnRecord": "***",
      "Attributes": {
        "ObjectType": "OrderLineItem"
      }
    }
  ],
  "Attributes": {
    "ObjectType": "Order"
  }
}


BillingCycle for provisioning is specified as monthly while it should be none for trial offers.


Cause


License type for trial offer was configured improperly. UID of trial offer was specified as Offer ID instead of Trial Offer ID.


Resolution


Reconfigure license type and corresponding service plan in accordance with Microsoft 365 application documentation:

License type configuration

Service plan configuration