Symptoms


Provisioning of sales order for Azure NCE subscription fails with the following error in /usr/local/azure-nce/log/azure-nce.log log file on the endpoint:


2020-06-20 12:23:10,153 ERROR [com.odin.azure.api.PartnerCenterApi$Slf4JLogger] (APS_task:1393549:38987_2891 https-jsse-nio-192.168.13.75-11443-exec-1) Partner service failed response:{
  "code": 600002,
  "message": "Date of agreement cannot be greater than the current date.",
  "description": "Date of agreement cannot be greater than the current date.",
  "errorName": "InvalidInput",
  "isRetryable": false,
  "parameters": {},
  "errorMessageExtended": "InternalErrorCode=600002"
}



Cause


Incorrect date and time settings are specified on Azure NCE endpoint. 


The application utilizes local time settings during requests. The time specified on the endpoint is ahead of the actual time which causes incorrect requests from the application.


Resolution


Set the correct time and date on the Azure endpoint. Check official RedHat documentation for details instructions:

Specify date/time in RedHat

NTP configuration


Notice that the time settings should be synchronized between the following servers in CloudBlue Commerce:


  • Azure application endpoint                                            
  • Management node server                                              
  • Billing application server                                              
  • Billing database server                                                
  • Billing online store server