Symptoms


Various APS-related operations fail with the error like this one in core.log:

Aug  4 10:46:36.201 : DBG [aps-service:34868 aps-service-task-232:28856 pau]: c.p.p.tracer entry: com.parallels.pa.service.security.ejb.ApsSecurityManagerBean.initActor(TokenData{scope={actor={id=e7b58516-f66b-41d5-8e04-5ed0c38f0560, type=http://parallels.com/aps/types/pa/serviceTemplate/1.2, pk=386496}}}, null) correlationId uispan:b4a8c79c-4b2f-48af-9259-0b914e2aca54
Aug  4 10:46:36.201 : DBG [aps-service:34868 aps-service-task-232:28856 pau]: c.p.p.tracer exit: com.parallels.pa.service.security.ejb.ApsSecurityManagerBean.initActor returning Actor: com.parallels.pa.se
rvice.registry.TypeIdParser$TypeId@676ca054:386496 correlationId uispan:b4a8c79c-4b2f-48af-9259-0b914e2aca54
Aug  4 10:46:36.201 : DBG [aps-service:34868 aps-service-task-232:28856 pau]: c.o.a.s.b.e.APSBoosterBean request: '/aps/2/resources' Actor: com.parallels.pa.service.registry.TypeIdParser$TypeId@676ca054:3
86496
Aug  4 10:46:36.346 : DBG [aps-service:34868 aps-service-task-232:28856 pau]: c.o.a.s.b.e.APSBoosterBean Error occurred while handling HTTP request via Booster: com.parallels.pa.service.aps.api.APSExcepti
on: Unknown property 'mpn_id'
        at deployment.core-ear.ear.aps-booster-ejb.jar//com.odin.aps.service.booster.domain.ApsResource.chooseAppropriate(ApsResource.java:302)
        at deployment.core-ear.ear.aps-booster-ejb.jar//com.odin.aps.service.booster.domain.ApsResource.filterAccessibleProperties(ApsResource.java:218)
        at deployment.core-ear.ear.aps-booster-ejb.jar//com.odin.aps.service.booster.domain.ApsResource.filterResource(ApsResource.java:151)
        at deployment.core-ear.ear.aps-booster-ejb.jar//com.odin.aps.service.jsonb.ejb.JsonbResourceHandlerBean.lambda$resourceList$5(JsonbResourceHandlerBean.java:357)


For example, the following error could be represented in Online Store on attempt to add item to the cart :

An error occurred
An error occurred during execution; please try again later.
Unknown property 'mpn_id'


Cause


Software-related issue #OA-15803.


Resolution


Contact CloudBlue Technical Support in order to apply internal workaround for the issue.