Symptoms

1. On an attempt to open the "Price List" or "Configuration" tab for Azure CSP Instance, the following error appear in PCP:

RESTEASY004655: Unable to invoke request

2. Periodic task "Azure Cloud Solution Provider <UID> Periodic Tasks Manager" fails with 500 code and the same error message.

The following error can be found in azure.log from the Azure CSP Endpoint:

2020-10-12 15:32:32,670 DEBUG [com.odin.azure.common.ClientLogs] (azure task-89) <APS> Outgoing request: GET https://170.20.20.100:6308/aps/2/resources/2e0b0dc6-ae1a-424e-8860-87af8cadbf2a
- headers:
Accept: application/json
Accept-Encoding: gzip, deflate
- body:
- end
2020-10-12 15:32:32,682 ERROR [com.odin.azure.server.ErrorsHandler] (azure task-89) <APS-APP> Error: com.odin.azure.APSClientException: RESTEASY004655: Unable to invoke request
at com.odin.azure.storage.aps.ApsStorage.getNonTransactional(ApsStorage.java:314) [classes:]

Caused by: javax.net.ssl.SSLHandshakeException: Received fatal alert: certificate_unknown

Cause

An endpoint is trying to send a request to the Management Node but fails. An instance certificate on the Azure Endpoint is expired due to software bug OA-17830 "Java aps controller generates 1y certificates instead of 15y".

Resolution

Please contact with CloudBlue Technical Support in order to renew a certificate manually.

Contact with Technical Account Manager in order to know status of the bug OA-17830


Internal


Internal link