Symptoms


Azure CSP subscription was transferred to a new Azure NCE plan on Microsoft side. Afterwards, new Azure NCE subscription was imported to the same OA account. However, it was noticed that old Azure CSP subscription is still being billed on OA side even though subscription is suspended and is not represented in invoices on Microsoft side.


Cause


This is expected behavior that after suspension of Azure CSP subscription it still could be invoiced with a resources which consumption is reported with delays on Microsoft side.


Resolution


In order to stop usage reporting for old Azure CSP subscription, it is required to access this particular subscription via Azure portal and delete all resources within it which have non-zero usage.


You can also check current resource usage for the suspended subscription by following instructions from Microsoft article: https://docs.microsoft.com/en-us/partner-center/develop/get-a-customer-s-utilization-record-for-azure

Below is the example of subscription with no usage:

GET https://api.partnercenter.microsoft.com/v1/customers/a0d24732-xxxx-xxxx-ad52-81a51244f277/subscriptions/70CE9281-xxxx-xxxx-8233-86A526B9DD89/utilizations/azure?start_time=2020-12-01T19:00:00Z&end_time=2020-12-10T20:00:00Z&granularity=Daily&show_details=true&size=500

{
    "totalCount": 0,
    "items": [],
    "links": {
        "self": {
            "uri": "customers/a0d24732-xxxx-xxxx-ad52-81a51244f277/subscriptions/70CE9281-xxxx-xxxx-8233-86A526B9DD89/utilizations/azure?start_time=2020-12-01T00:00:00Z&end_time=2020-12-09T00:00:00Z&granularity=Daily&show_details=True&size=500",
            "method": "GET",
            "headers": []
        }
    },
    "attributes": {
        "objectType": "Collection"
    }
}


Internal