Symptoms

Azure CSP subscription was transferred to Azure Plan. Afterwards, a new Azure NCE subscription was imported to the same account. However, old Azure CSP subscription is still billed from CloudBlue Commerce side even though subscription is suspended and is not represented in invoices on Microsoft side.


Cause

When subscription is transferred to Azure Plan (Azure NCE subscription), it's suspended from Microsoft according to the following policy https://docs.microsoft.com/en-us/azure/cost-management-billing/manage/cancel-azure-subscription

When subscription is suspended from Microsoft side, a special storage resource left for subscription to restore it according to the Cancellation Policy. 


At the same time, Azure CSP application receives usage for such subscription and generates Billing Orders until subscription from Microsoft side is deleted (after 90 days).


Resolution

1) After the subscription is transferred from CSP to NCE, contact with end-customer(subscription owner) to confirm that the data is successfully transferred and everything works as expected.
2) Delete Azure CSP subscription from Partner Center after confirmation with the subscription owner.


Internal

Internal link