Symptoms
Resellers's staff members and Account's staff members are receiving notifications with subject "The customer has wrong contact data" and body
"Microsoft 365 has found that some fields of contact data for customer 'XXXXXXXX' contain incorrect information. Please log into CCP, check and correct it" even if they are not subscribed to the "Office 365 Customer has wrong contact data" notification template from the PCP or RCP side.
Cause
Starting from the Microsoft365 v20.2, application notify staff members of a Reseller and Account in case incorrect information was provided in Sales Order and application was not able to create new Microsoft Account.
Resolution
Please use the documentation page to adjust Notification settings for Microsoft365 application: https://docs.cloudblue.com/cbc/services/microsoft365/20.3/content/Providers-Guide/Notification-Messages.htm