Symptoms

Azure CSP Subscription was transferred to Azure Plan. Afterwards, Azure NCE subsciprion was imported from Microsoft to CloudBlue Commerce. However, old Azure CSP subscription is still billed by CBC during the next 3 month even though the subscription is suspeded and not represented in invoices on Microsoft side. 


Cause

When the Azure CSP Subscription was transferred to Azure Plan, a storage resource was left under Azure CSP Subscription and it retured a usage. The storage resources are not deleted by default since these are kept available in case of data retention or recovery. After the 90 days post suspention these resources are deleted by Microsoft. Hence, even after the subscriptions is suspended, the usage can be seen because of these resources. After the subscription is suspended, the billing is stopped immediately from the Microsoft side, but Azure CPS application was using GET customer's utilization records for Azure API call and receive usage for the storage resource until the subscription was not delted from Microsoft side after 90 days.


Resolution

1) After Subscription is transferred from CSP to NCE, contact with end-customer to confirm that the data is successfully transferred and everything works as expected.

2) Delete CSP subscription from Partner Center after confirmation with end-customer.


Internal

Internal link