Symptoms

Provisioning of the addon subscription fails with the following error message:

Task "Delivering of event notification Resource limits changed" (id = <id>) is failed with error: "'500 Internal Server Error' received from 'POST https://<endpoint.url>:443/o365app01/aps/tenants/<tenant_id>/onCoreSubscriptionChanged: Addon with offerId <offerId> is not related to the specified parent subscription id <subscription_id> " 


Cause

Addon in question has 2 or more parents specified, whereas some of these parents are incorrect. 

During the addon provisioning M365 APS uses the following logic:

1. If, for example, addon has 3 possible parents. Customer has all 3 licenses provisioned:

- 1st with quantity 5

- 2nd with quantity 7

- 3rd with quantity 9

2. Licenses with quantity 7 and 9 are specified as parents incorrectly. According to MSFT Offer Matrix, only license with quantity 5 should be specified.

3. M365 APS will always choose the parent with the most quantity. In the example above, it will try to provision addon for the license with quantity 9. 

As a result, Partner Center will return 500 error "addon with offerId <offerId> is not related to the specified parent subscription id <subscription_id>".


Resolution

Please contact CloudBlue technical support in order to apply internal workaround.


Internal

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