Symptoms
On attempt to adjust budget cap settings for Azure CSP subscription from Customer Control Panel, the "could not execute batch" error occurs.
CCP > Azure > Administration > Manage > Email Alerts > Configure
Cause
Case#1
Software related issue OA-7784
Case #2
Azure CSP Database inconsistency where information between Tenant APS resource and DB are different.
Tenant APS resource - vendor budget cap settings
"vendor_budget_cap_settings": { "disable_notification": false, "name": "Custom", "settings": { "budget_cap": 300.000000, "enabled": true, "enabled_daily_notification": false
Azure CSP DB vendor badget cap settings for a particular tenant
disable_notification | tenant_oss_id | budget_cap | enabled_daily_notification ------------+----------------------+--------------------------------------+--------------------------------------+ n | 17592b2e-ac62-438b-8de8-8936d0515c76 | 300.0000 | n n | 17592b2e-ac62-438b-8de8-8936d0515c76 | 300.0000 | n n | 17592b2e-ac62-438b-8de8-8936d0515c76 | 10000000000000000000.0000 | n n | 17592b2e-ac62-438b-8de8-8936d0515c76 | 300.0000 | n (4 rows)
DB inconsistency could be caused by different reasons. As an example,budget cap notifications were disabled for subscription (represented as values for http://www.odin.com/app/azure-csp/tenant/2.15. Example is below), but corresponding entry remained in "tenant_budget_cap_settings" table.
Resolution
OA-7784 software bug has been fixed in Odin Automation Premium 8.3.
Please contact CloudBlue Technical Support to apply workaround and fix the issue.