Symptoms

Starting from Microsoft365 v 20.3 it's possible to upgrade a license even if the Source and Target license limit do not match.

When source subcription was transferred to target subscription, user licenses were not reassigned automatically.

Cause

According to the documentation page:

Upgrades are supported for a limited number of licenses. You must use your product catalog to obtain information about possible upgrades from one license to another license.

Even if Offer Matrix from Microsoft Partner Center is filled out with a "Can Convert To" field for a particular offer

GET request with REST API client using Partner Token shows that there are no "conversionTargetOffers" or "upgradetargetOffers" offers exist for a particular source offer:


GET https://api.partnercenter.microsoft.com/v1/offers/796b6b5f-613c-4e24-a17c-eba730d49c02?country=GB
...
.....
"isAutoRenewable": true,
    "isInternal": false,
    "isTrial": false,
    "conversionTargetOffers": []


Subscription was transferred to a desired plan by the Microsoft365 application design, where the source subscription was disabled/suspended and user's licenses were not transferred to the target subscription as there no target offers were found during the transition.


Note:

1. "conversionTargetOffers"  offer parameter- it's used for converting the Trial Ofers to the paid one.

    "upgradetargetOffers" offer parameter - it's used for upgrade of the subscriptions.

     One column in Offer Matrix file is used for both scenarious as only one of them can be used for a particular offer.


2. Transision a subscription Microsoft API Reference: https://docs.microsoft.com/en-us/partner-center/develop/transition-a-subscription




Resolution

Please reach out Microsoft Support to clarify why Offer Matrix from Partner Center contains the outdated information.



Internal