Symptoms

A new Perpetual Software License is configured according to the documentation page https://docs.cloudblue.com/cbc/services/microsoft365/20.3/content/Providers-Guide/How-to-Add-New-Software-Subscription-Licenses-and-Perpetual-Software-Licenses-on-an-Existing-Installation-of-the-Application.htm


A new Sales Order is failed with an error message:

'500 Internal Server Error' received from 'POST https://O365CSP.domain.local:443/O365CSPApp/aps/tenants': This software license cannot be purchased for this combination: product id 'DG7GMGF0F4K0', and sku id '0002', target segment 'commercial' and country 'us'.


Cause

Check the product using REST API client and Partner Token.

The request returns two element (instead of 1).

GET https://api.partnercenter.microsoft.com/v1/products/DG7GMGF0F4K0/skus/0002/availabilities?country=US&targetView=SoftwarePerpetual&targetSegment=commercial
{
    "totalCount": 2,
    "items": [
        {
                       "id": "DG7GMGF0DTZ3",
            "productId": "DG7GMGF0F4K0",
            "skuId": "0002",
            "catalogItemId": "DG7GMGF0F4K0:0002:DG7GMGF0DTZ3",
            "defaultCurrency": {
                "code": "USD",
                "symbol": "$"
            },
            "segment": "commercial",
            "country": "US",
            "isPurchasable": true,
...
.....
.......
            "id": "DG7GMGF0DTXG",
            "productId": "DG7GMGF0F4K0",
            "skuId": "0002",
            "catalogItemId": "DG7GMGF0F4K0:0002:DG7GMGF0DTXG",
            "defaultCurrency": {
                "code": "USD",
                "symbol": "$"
            },
            "segment": "commercial",
            "country": "US",
            "isPurchasable": true,

This case is not documented by Microsoft.

The Microsoft 365 application doesn't handle multy results from the query above.


Resolution

Please submit a Support Request to Microsoft to clarify if this is the correct response to the query. 


Internal