Symptoms


The Kaspersky subscription Sales Order is failed with the output:

Service Creation Failed: Platform service was not created. Task "Provisioning "tenant" for APS application Kaspersky Small Office Security(https://10.35.200.18:443/ksos/)" (id = 4047980) is failed with error: "could not prepare statement IJ031070: Transaction cannot proceed: STATUS_MARKED_ROLLBACK "

The certificate has expired as observed from the endpoint log /var/log/aps/kaspersky-ksos.log:

Apr 30 00:46:46 debug APS-kaspersky-ksos[29488]: DEBUG  29488 tenant::log_line A:1009599-S:1025784 Service Plan Product: {"id":"1004280","resourceId":"c4f94dcb-1bd1-4b7d-a774-453f0594b966","title":"Kaspersky Small Office Security 1 Desktop","apsId":"735f137b-4810-4613-86e9-dfe4bfbfe56d","apsType":"http:\/\/www.kaspersky.com\/aps\/ksosApp\/product\/1.0","usage":0,"limit":1,"unit":"unit"}
Apr 30 00:46:46 info APS-kaspersky-ksos[29488]: INFO   29488 A:1009599-S:1025784 Service Plan Product: Kaspersky Small Office Security 1 Desktop
Apr 30 00:46:48 err APS-kaspersky-ksos[17316]: ERROR  17316 6008: Provided certificate has already expired or not valid yet. Valid from 2020-02-10 to 2021-02-19


Checking on Control Panel (Services > Application > Kaspersky Small Office Security), the current certificate has been expired:

Cause

The Kaspersky Small Office Security certificate is expired.


Resolution

Update Authentication Certificate from Provider Control Panel (Services > Application > Kaspersky Small Office Security > Settings)