Symptoms


Trying to add a new hardware node to the platform and the task fails.

Task 

Name: "Execute operation '/register_compute_node_task' with ID xxx on resource yyy"
Description: Registering compute node
Last execution output:

'500 Internal Server Error' received from 'POST https://OACI_ENDPOINT:9000/api/cloud/zzz/register_compute_node_task': The application returned an error message with a non-parsable JSON. Check the application logs to find out what went wrong.

In its execution log we see this error message "Host #x with similar properties already exists."


Cause

The host with similar parameters (usually hostname) might have already been registered as a Cloud Infrastructure node.


Note: Due to changes in internal logic and UI of Cloud Infrastructure, newly added nodes cannot be observed in 

OA > Infrastructure > Service Nodes

but instead are visible in 

OA > Services > Cloud Infrastructure > Virtualization Nodes (or Backup Nodes). 


So please check all those locations.


Resolution

If you have found such a host in the platform:

1. Cancel the task tree of the failed registration task.

2. Rename your new node (give it a unique hostname that is not being used in the platform).

3. And then try registering it once again.


If you have not found it, this article might give some explanation - https://cloudblue.freshdesk.com/support/solutions/articles/44001886714-cannot-add-windows-node-similar-host-already-exists