Symptoms
Unable to assign the Acronis service to an account with error below:
Failed to assign the backup service from subscription XXXXX to the user "Username" because it's already assigned from subscription YYYYY
Cause
Previous subscription YYYYY was not destroyed properly with failed task in Operations side.
Task name: "Unprovisioning "tenant" for APS application Acronis Backup Cloud"
On the first attempt, the task was failed with
'404 Not Found' received from 'DELETE https://10.20.104.19:10443/backupservice/users/292fcc66-a4a4-408d-ae1a-955199c76978': Not Found: The service is currently not available. Please try again later.
Next attempts fail with
'500 Internal Server Error' received from 'DELETE https://10.20.104.19:10443/backupservice/users/292fcc66-a4a4-408d-ae1a-955199c76978': Internal Server Error: Empty result from APSC by the following link: APS\Link Object ( [id] => [href] => aps/2.2/resources/292fcc66-a4a4-408d-ae1a-955199c76978/user [link] => strong [name] => user [collection] => )
The user account was absent on Acronis side during the first deletion attempt. However, the task removed the link to users which caused the second failure.
Resolution
Please contact CloudBlue Technical Support to apply a workaround.