Symptoms


Sales Order for CB Connect application is failed with an error message

Provisioning failed orders due to error, Service Creation Failed: Platform error #error_code #-1, extype_id #-1, module_id #, '500 Internal Server Error' received from 'POST https://qs.connect.cloud.im/connector/tenant': {'code': 400, 'error_code': 'SYS_001', 'errors': ['There is no Listing for specified Product and Marketplace.']}.


Cause

Product is not listed for a Provider from the CloudBlue Commerce side. The listing process is not comleted.


Resolution

1. Make sure that the proper relationships arranged (agreement and contract) at the Connect portal between Product Vendor and Service Provider.

2. Make sure that the listing process is completed as it's mentioned in CloudBlue Connect Community portal: https://connect.cloudblue.com/community/modules/listings/