Symptoms


On attempt to change limit for customer's subscription from L1 Reseller Control Panel (RCP > Customers > find subscription > click to Change button > adjust limit for a license > click Next button), the following error occurs

An unknown error occurred in the Microsoft 365 application.


It can be seen that the API URL that was sent through browser - 

"aps/2/resources/7c8ba5ac-528d-417c-a531-3d5efad7ae4f/pc/plans?planId=in=(4669,4647) " returns empty result, where 4669 - delegated L1 Reseller's Service Plan, 4647 - Provider's Service Plan.

Cause

Provider's Service Plan is not added to any Sales Category.

Resolution

Make sure that Provider's Service Plan is added to a Sales Category.