Symptoms
The error message occurs on attempt to open Settings > Connect tab from Provider Control Panel
Unable to load /aps/2/resources/XXXXXXX/healthCheck: status: 500 and an error In handleAs: transformation of response"
core.log on Management Node shows that GET request is failed
Sep 27 11:37:30.611 : DBG [aps-service:5939921 aps-service-task-102574:232462 pau]: c.p.p.s.a.RootRoutingServlet request from 192.168.90.15:58174 GET https://192.168.90.10:6308/aps/2/resources/fdb7a3de-3d2f-455a-9ab7-0ea9022f97bf/healthCheck
Sep 27 11:38:00.695 : DBG [aps-service:5939921 aps-service-task-102574:232462 pau]: c.p.p.s.c.e.EndpointExecutorBean End request: 'GET https://aps.connect.cloudblue.com/hub/globals/fdb7a3de- 3d2f-455a-9ab7-0ea9022f97bf/healthCheck' '500 Internal Server Error'
This is visible from the core.log that Proxy is used
Sep 27 11:37:30.615 : DBG [aps-service:5939921 aps-service-task-102574:232462 pau]: c.p.p.tracer exit: com.parallels.pa.service.config.ejb.ConfigurationManagerBean.getParam returning ConfigrationParam: 'APS_PROXY_OUT_ENABLED'=1 correlationId uispan:3d508bf9-1479-4744-b5ca-f363feba96f9 Sep 27 11:37:30.615 : DBG [aps-service:5939920 aps-service-task-102584:232493 pau]: c.p.p.tracer exit: com.parallels.pa.service.config.ejb.ConfigurationManagerBean.getParam returning ConfigrationParam: 'APS_PROXY_OUT_HOST'=192.168.5.95 correlationId uispan:2285bb38-717d-4959-9de7-a326dc8b4a5a Sep 27 11:37:30.617 : DBG [aps-service:5939920 aps-service-task-102584:232493 pau]: c.p.p.tracer exit: com.parallels.pa.service.config.ejb.ConfigurationManagerBean.getParam returning ConfigrationParam: 'APS_PROXY_IN_URL'=https://cbproxy.yourdomain.com:6308 correlationId uispan:2285bb38-717d-4959-9de7-a326dc8b4a5a
Connection to connect-cbc-adapter is not working
[root@osscore pa]# curl -v connect-cbc-adapter * About to connect() to connect-cbc-adapter port 80 (#0) * Trying 10.90.250.150... * Connection timed out * Failed connect to connect-cbc-adapter:80; Connection timed out * Closing connection 0 curl: (7) Failed connect to connect-cbc-adapter:80; Connection timed out [root@osscore pa]# telnet 10.90.250.150 80 Trying 10.90.250.150... telnet: connect to address 10.90.250.150: Connection timed out
Cause
Network related issue. Proxy is not working as expected.
Resolution
Please make sure that Proxy host is configured with the official CloudBlue Connect documentation https://catalog.cloudblue.com/extensions/cloudblue-commerce/configuration-prerequisites/prerequisite-2-proxy-configuration/