Symptoms

After microservice or extension ux1-marketplace has been successfully upgraded or restarted , respectively at Sales Channels > Reseller Marketplace and/or Sales Channels > End-customer Marketplace it is stated that:


The reseller marketplace is paused and unavailable for customer
The end-customer marketplace is paused and unavailable for customer

Example in a screenshot:


And then, clicking on Resume Marketplace button returned error similar to below:

Unable to create new marketplace settings: Account "<GUID>" already has settings for the 'Reseller' channel. Probably, you need to restart the 'UX1 Marketplace [GUID] Plan indexer task' to actualize content in the storage.

Example in a screenshot:



Cause

After UX1 Marketplace has been successfully upgraded or restarted, it is required to manually run Periodic task named "UX1 Marketplace [GUID] Plan indexer task" to actualize the marketplace content in the storage.


Location of said task:

Go to PCP > Operations > Task > Periodic > In name field type in the word 'Plan Indexer task' > Click Search

Example:

Resolution

Run the periodic task 'UX1 Marketplace [GUID] Plan indexer task' manually.



Internal