Symptoms
The following error appears on the node in the Event Viewer:
Event Type: Error Event Source: Ntfs Event Category: Disk Event ID: 55 Description: The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume \Device\VZLPBKVolumes\VZLPBKVolume{F9B7EA79-9590....For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Cause
The virtual disk of the container with GUID (starting with "{F9B7EA79-9590") is corrupted.
Resolution
List the GUIDs of all VEs and choose the required one:
for /F %i in ('vzlist -Hao veid') do vzcfgt get %i GUID && echo is GUID of VE %i
Stop the issued CT:
vzctl stop CTID
Make a copy of "z:\vz\private\CTID\root.efd" in case of emergency.
Mount the "root.efd" file:
vzdskctl mount z:\vz\private\CTID\root.efd GUID
If this step cannot be completed, for example:
C:\Users\Administrator>vzdskctl mount c:\vz\private\101\root.efd {3B461D9D-D930-4FD8-9D2C-898166C222A1} FAILED
Refer to: 113728 "Issues caused by high fragmentation of root.efd"
Run "chkdsk" on the mounted "root.efd" file:
chkdsk /f \\?\VolumeGUID
(where "GUID" (after "Volume") is the value obtained in step 1)
When the process is finished, unmount the "root.efd" file:
vzdskctl umount GUID
Start the CT:
vzctl start CTID
A real-life example:
vzctl stop 115
vzcfgt get 115 GUID
vzdskctl mount c:\vz\private\115\root.efd {799251BE-720C-468E-B877-913F49476001}
chkdsk /f \\?\Volume{799251BE-720C-468E-B877-913F49476001}
vzdskctl umount {799251BE-720C-468E-B877-913F49476001}
vzctl start 115
Note: This approach works for additional drives added via the Mount manager, including drives D:\ or E:.
Use the additional drive's GUID from "c:\vz\conf\VEID.conf" instead of the VE's primary GUID to perform the same operations. See this GUID example for drive D:
DRIVE_D="type=loopback;file=lpbk0000.efd;guid={cc4a1cb5-9f9d-47ac-a09f-0e6b87643105 };"
Additional Information
Corrupted permissions may cause various inconsistencies inside containers. As a result, operating system components and applications may continue malfunctioning even after you have fixed the permissions issue.
If you come across this behavior and are unable to quickly diagnose and fix it, it is recommended you consider restoring the container from a backup or even creating a new empty container and moving the old data from the corrupted container manually.