Symptoms

Sales Order is failed with an error from CB Commerce side:

Fulfillment Request PR-8604-6136-****-*** created. State set to Failed.
Reason: There has been an error on checkout the cart: For the current term, the requested number of 1 asset(s) exceeded the remaining limit of -1 assets allowed per customer.

and PR-request is failed from the CB Connect side with an error in Microsoft365 connector log:

PR-8000-6000-****-*** MICROSOFT_AAD_API_Response "POST" : "https://api.partnercenter.microsoft.com/v1/customers/ff46qefu-845b-4efc-b9ea-*****/carts/c1c07c9c-aefe-42fc-b16t-8a1a95f06f39/checkout", MS-CorrelationId:"3a8a50d0-c7eb-11ec-89e6-******", MS-RequestId:"3a8a50d0-c7eb-11ec-******" : {'orderErrors': [{'orderGroupId': '0', 'code': 800089, 'description': 'For the current term, the requested number of 1 asset(s) exceeded the remaining limit of -1 assets allowed per customer.', 'attributes': {'objectType': 'OrderError'}}], 'additionalInformation': [], 'attributes': {'objectType': 'CartCheckoutResult'}}

Cause

An issue from Microsoft side.

Resolution

Please contact Microsoft Technical Support and provide them MS-RequestId to investigate the issue further.