Symptoms


Attempt to purchase the particular NCE product in Reseller UX1 marketplace fails with an error:

Following error occurred:java.lang.NullPointerException


The browser debug console could catch the 'validate' request with the same error message:

https://cp.test-environment.com/aps/2/resources/bd0d665f-3b24-4c66-be8f-70b76f21953b/validate
{error: "com.ingrammicro.imcp.library.aps.exception.APSError",…} error: "com.ingrammicro.imcp.library.aps.exception.APSError" http_request: "POST https://inhouse-products:8081/rest/application/bd0d665f-3b24-4c66-be8f-70b76f21953b/validate" message: "java.lang.NullPointerException" packageId: "9836100d-7bb7-4853-ba12-e5aa3c0a0c0c"


Pay attention to the 'items' value right before the exception in the inhouse-products pod log:

14-06-2022;09:20:44,205 INFO  [769253ed-557e-4a99-19f6-aefb6f50d2c4 application-rest:task-49:6836 inhouse-products] c.o.p.a.r.ApplicationInstanceService - ValidationRequestDTO: ValidationRequestDTO{draf
tRequestId='null', activationParameters=[ActivationParameter{key='tenant_preference', value='existing', structured_value='null'}, ActivationParameter{key='microsoft_domain', value='.onmicrosoft.com', st
ructured_value='null'}, ActivationParameter{key='effective_address', value='', structured_value='null'}, ActivationParameter{key='effective_city', value='', structured_value='null'}, ActivationParameter
{key='effective_state', value='', structured_value='null'}, ActivationParameter{key='effective_postal_code', value='', structured_value='null'}, ActivationParameter{key='effective_country', value='', st
ructured_value='null'}, ActivationParameter{key='mca_acceptance', value='', structured_value='null'}, ActivationParameter{key='first_name_agreement', value='', structured_value='null'}, ActivationParame
ter{key='last_name_agreement', value='', structured_value='null'}, ActivationParameter{key='email_address_agreement', value='', structured_value='null'}, ActivationParameter{key='agreement_date', value=
'', structured_value='null'}, ActivationParameter{key='relationship_url', value='', structured_value='null'}, ActivationParameter{key='education_auth', value='', structured_value='null'}, ActivationPara
meter{key='migration_info', value='', structured_value='null'}, ActivationParameter{key='customer_tax_id', value='', structured_value='null'}, ActivationParameter{key='mpn_id', value='', structured_valu
e='null'}, ActivationParameter{key='effective_phonenumber', value='', structured_value='null'}, ActivationParameter{key='gcc_code', value='', structured_value='null'}, ActivationParameter{key='activatio
n_link', value='null', structured_value='{YES=false}'}, ActivationParameter{key='offer_attestation', value='null', structured_value='{attestation_accepted=false}'}, ActivationParameter{key='customer_com
pany_name', value='', structured_value='null'}, ActivationParameter{key='customer_email', value='', structured_value='null'}, ActivationParameter{key='partner_on_record_attestation_accepted', value='nul
l', structured_value='{attestation_accepted=false}'}, ActivationParameter{key='special_qualifications', value='', structured_value='null'}, ActivationParameter{key='additional_mpnids', value='', structu
red_value='null'}, ActivationParameter{key='migration_type', value='', structured_value='null'}], items={1006738=CartItem{quantity=7, resourceApsId='null'}}}
14-06-2022;09:20:44,206 WFLYEJB0034: Jakarta Enterprise Beans Invocation failed on component ProductManagerBean for method public abstract com.odin.platform.application.rest.PdiProduct com.odin.platform
.application.api.ProductManager.getPdiProductByApsId(java.lang.String): javax.ejb.EJBException: java.lang.NullPointerException

Cause

The resource type with the ID from the inhouse-products log is absent from the Service Template that reseller is trying to purchase.

Resolution

Add the Resource Type to the Service Template back.