Symptoms

Some Service Plans are missing from Product Inventory.

Cause

Product Inventory misconfiguration. A particular resource has a different cost (recurring fee) for different Service Plans which is controverted with the official documentation https://docs.cloudblue.com/cbc/20.5/premium/content/Billing-Providers-Guide/add-products-to-product-inventory.htm

  • The resource rate price is the same in all service plans offered by the account.
 PlanID | PlanRateID |  setupFee  | recurringFee | costForAdditional
--------+------------+------------+--------------+-------------------
 248729 |     931171 | 0.00000000 |  48.00000000 |        0.00000000
  68616 |     555114 | 0.00000000 |   4.00000000 |        0.00000000
(2 rows)


Resolution

There are two ways to fix the issue:

1. Unpublish one of the problem service plans. Prices are validated only in published plans. After that, Product Inventory will work correctly with the published plan.
2. Set equal prices in all service plans for the same products. After that, the product will pass prices validation.


Internal

Internal article