Symptoms


Importing new PPR file the following error shows up in provider UX1:


Following products were not found for account #1: Power Apps per app plan (1 app or portal), Common Area Phone, Operator Connect Mobile

Cause

There are two possible causes of this error:


  1. The products in the error don't  exist on product catalog, most probably due to the fact that the product catalog is not up to date. This can be checked from UX1 in the Portfolio section -> External catalogs for the product being imported. If the 'Version in portfolio' is different from 'Available version', then an update of the product is required.
  2. The product names in the error do not exist in the connect provider portal anymore, or never existed, this need to be confirmed in Connect portal.



Resolution


Depending on the cause of the issue:


  1. If the product is not up to date, it is needed to update the product catalog from the provider UX1, in Portfolio -> External Catalog, find the product being imported and click on it, then click on Update button and want for the task to be completed before import the PPR file again.
  2. In case the product do not exist on Connect side or the name has changed, then the PPR file must be reconfigured based on the new product names and convections on connect portal.