Symptoms

In Coudblue Commerce 20.5 and 21.0, change orders can get stuck in the "Waiting for acceptance of the Terms and Conditions" status.


Cause

This can occur in the following scenarios:

  • After a platform upgrade, when enabling the default order flow, the related account does not accept the Terms and Conditions.
  • After migrating a subscription, when the related service plan is switched, upgraded or downgraded.


Resolution

For BSS 21.11 and below:


To get the change order unstuck, complete the following steps:

  • Download the attached script
  • Run the command /usr/local/bm/tools_py/patcher.py accept_multiple_terms.py


Then, according to your instance:

  • For classic deployment, run the script on the PBA node 
  • For CNC deployment, run the script on any bss-worker pod


No system restart is required.


For BSS 21.12 and above:


Under review.