Symptoms

Billing Order was generated for a Connect based subscription without SKU.


Cause

1. Check if this is not your case https://cloudblue.freshdesk.com/a/solutions/articles/44001888759

2. Verify that the subscription is rated by VRDM, i.e. not switched to Rating Engine yet.


If so, unfortunately, VRDM component cannot assign SKU to charges that were imported from external systems (in your case - from Connect).

There is an existing feature request to implement such functionality - #PFR-4355 - Ability to assign SKU to charges imported via VRD Manager


Resolution

Shift the corresponding plans and subscriptions to Rating Engine (RE):

https://docs.cloudblue.com/cbc/20.5/premium/content/Rating-Engine/Rating-Engine-shift-existing-subscriptions-to-rating-engine.htm

Warning: Rating Engine has its own limitations, please test it thoroughly on LAB before applying on Production.