Symptoms


Customer is using external mail relay server without authentication. Checking the configuration on bss-scheduler pod  /usr/local/bm/conf/AMAIL-users.db:

[root@bss-scheduler-5d945b87c4-qptvk /]# cat /usr/local/bm/conf/AMAIL-users.db
[Server]
Host = 123.123.123.123
Port = 25

Under Billing > System > Log > Outgoing E-Mail Log there are a lot of Outgoing E-Mails are in failed state with error:

mailsmtp_rcpt(example@cloudblue.com) failed with code error 1:'Unexpected error code' 

The relay SMTP server is responding with unexpected error on RCPT stage. To confirm what is the exact error following commands can be executed on the bss-scheduler pod one by one:

1) telnet 123.123.123.123 25
2) EHLO bss-scheduler-859cb54f4d-prlvq
3) MAIL FROM: noreply@cloudblue.com
4) RCPT TO: example@cloudblue.com

Resulting a response similar to this: 

454 4.7.1 <example@cloudblue.com>: Relay access denied 

Cause


Incorrect SMTP server configuration. Server doesn't allow to send your email to that domain. 


Resolution


Please check documentation for your smtp server and configure it properly.