Symptoms


Scheduled orders are not showing as processed in Commerce even when they have gone through Connect. Also, the status in Commerce is 'Activation is scheduled'.


Status in Commerce:


Status in Connect is Approved or Scheduled:


Cause

If the order is placed after the RN date, the order will be in 'Activation is scheduled' until the next month's BO. There is more information in the following link: https://docs.cloudblue.com/cbc/21.0/Billing-Providers-Guide/Scheduled-subscription-changes.htm


In Connect, scheduled orders can be active or scheduled while awaiting for the Requested Activation date. When the PR is placed it is in Scheduled status, but on the Renewal Date (check Connect > Subscription > Billing) it became active. 


It is possible that a Requested Activation date is prior RN date, but the connector will schedule the request until the day before the renewal date.


Resolution


The order will be processed in Commerce on the next BO date.