Symptoms


The Subscription Resources dataset for RDE returns the wrong Unit Price for a resource, whereas provisioned order and subscription resource show the correct one.




After generating the RDE report, the column from the Subscription Resources datasheet does not contain the same information that can be seen in the subscription and Billing Order resources fee after synchronization. 


Cause

This issue affects accounts with special pricing. 


To check if an account has special pricing applied to it go to: Home > Operations > Account > Subscription > General (tab) > Search for Promoted by option. Option 'Applicable To Renewal' has to be enabled for the price to be in 'promotion mode'.


Resolution


Promotions are not included in the subscription resources datasheet. Therefore, the report shows the resource price without promotion. This issue will be fixed in the scope of RDEX-440.