Symptoms

A Scheduled Change Order, that was placed after a Renewal Order and before the Expiration Date fails due to the below error:

Microsoft commitment end date 2023-02-06 00:00:00 ( +1 day renewal day) and planned renewal date sent to the request 2023-03-07 00:00:00 are not aligned, please try once the dates are aligned

As can be seen from the above error, there is a one-month mismatch between Microsoft and Commerce.

Cause

This issue happens when the subscription auto-renews prior to the Expiration Date. 


The problem is that in Commerce the renewal takes place before the expiration date. On that date, the expiration date is moved one month or one year, depending on the period, forward. However, on Microsoft's side, the changes take place on the expiration date and this causes a mismatch leading to a failed Change Request.


Resolution

Any Scheduled Order that is placed in the time frame between the Renewal and the Billing Order is going to fail. To workaround this issue, a new scheduled order has to be placed after the Billing Order is provisioned.
"PFR-6440 - Controllable behavior of manual 'Renew' action" exists to improve the platform behavior and cover such scenarios. Please contact your Technical Account Manager or pta@cloudblue.com to clarify the status of the feature request.