Symptoms


Customer placed an order and create google workspace based subscription using specific domain without any issues.

Then, same customer placed second sales order to create new subscription for different plan using same domain, but this time provisioning fails with failed task:

Service Creation Failed: Platform service was not created. Task "Provisioning "subscriptionService" for APS application Google Workspace(https://aps.connect.cloudblue.com/connector)" (id = 5190877) is failed with error: "'409 Conflict' received from 'POST https://aps.connect.cloudblue.com/connector/tenant':

The purchase request PR-1234-1234-1234-123 has not been completed.
The vendor has rejected the request with following reason:

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Message from the Vendor: GOOG_003: This Google account already has an active entitlement for Google Workspace Business Standard Flexible. It is not possible to have several entitlements for the same product.

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Important note: submitting again this order will fail due previous reason
please create a new purchase request to correct it or contact support


Cause

Google does not allow to purchase of two subscriptions for the same family product, in this case, "Google Workspace". The customer is trying to purchase two subscriptions for the same product but with different SKUs, Google Workspace business starter flexible and Google Workspace business standard flexible for example in this case.


Once the connector detects that there is a subscription purchased for the same product, it is not allowed to purchase a new one.


Resolution

Customer need to cancel the failed order and won't be able to place new order for same family product.